I'm actually excited I just broke my ejector on my MP5K PDW Clone... - Page 2
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
Like Tree5Likes

Thread: I'm actually excited I just broke my ejector on my MP5K PDW Clone...

  1. #11
    Member
    hatter665's Avatar
    Join Date : Dec 2009
    Location : Seattle, WA
    Posts : 77
    Mentioned
    0 Post(s)

    Default

    Spitfyr thank you! Finally this gun is running flawlessly. Without a doubt, the side the side wiggle in the ejector was my problem. It's been five years of trying to figure out the root cause of this issue, buying part after part, but I can now say that I'd grab this gun without hesitation were the **** to hit the fan... I will post a video once I get a chance, I have a lot of guns to clean today. I took my wife and daughter shooting...

  2. #12
    Desperately Needs Treatment
    Spitfyr's Avatar
    Join Date : Jan 2010
    Location : Arizona
    Posts : 1,445
    Mentioned
    0 Post(s)

    Default

    I love it! Appreciate you letting us know the fix. I took a great friend of mine to Scottsdale Gun Club yesterday and we put a case of 9 through my CA89 and CA94 guns - they ran great and I'm happy to hear yours is too. Shoot the sh!t out of that gun and enjoy yourself my friend.

  3. #13
    Member
    hatter665's Avatar
    Join Date : Dec 2009
    Location : Seattle, WA
    Posts : 77
    Mentioned
    0 Post(s)

    Default

    https://www.youtube.com/watch?v=VpBKnQISosQ

    That's the link to the video from shooting today.

  4. Remove Advertisements
    HKPro.com
    Advertisements
     

  5. #14
    Senior Member
    Ferdfarming's Avatar
    Join Date : May 2015
    Posts : 126
    Mentioned
    0 Post(s)

    Default

    awesome you got it fixed, interesting root issue. great call Spitfyr!

  6. #15
    Desperately Needs Treatment
    Spitfyr's Avatar
    Join Date : Jan 2010
    Location : Arizona
    Posts : 1,445
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by hatter665 View Post
    That's the link to the video from shooting today.
    I had this same issue a while back and it took a bit of head scratching and help from this board to get it figured out. Happy to help and great video!

  7. #16
    Member
    hatter665's Avatar
    Join Date : Dec 2009
    Location : Seattle, WA
    Posts : 77
    Mentioned
    0 Post(s)

    Default

    Here we go again... I had a PCS last year from Hawaii to Washington State. A few months back I took the same CA89 out to the gravel pits with some buddies from work. To my surprise, I had the same issues as before only more often. At first I thought it was because I was using Winchester White Box 124gr. instead of the Remington 124grain or my own 124grain reloads. I set my reloading bench up and made a couple hundred bullets. I cleaned my gun paying special attention to the flutes and I went back to the pits. I tested the same recipe that I had used successfully in Hawaii and the weapon still had failures to extract/eject. The gun went from shooting four magazines rapid fire with an assortment of ammo and no failures, to failures every couple rounds. I really want to figure this out because I'm eight months into my wait for an SBR tax stamp. Here' what I've done since that second trip and here's what I'm going to do next.

    After my second trip testing ammo I rechecked the bolt gap; it was within HK spec (.018). I checked the extractor and I can not move it at all with my thumb. I tried cycling live ammo manually via the cocking lever and sometimes rounds do dribble out, or fail to eject (though they did extract from the barrel/chamber). I thought it might be because I was getting tired of manually cycling, but I'm not for sure. When I shoot the gun, the brass flies like 6 feet, except for when it doesn't leave the receiver at all. It generally gets caught between the cocking tube and the receiver, double feeds, or stove pipes, it's just like the pics I posted originally. For good measure I changed out the extractor since I had a new RCM one. Though the rifle spring I was using had less than 200 rounds, I installed a new one. Because I had already changed out my hammer spring to a new 9mm one, my ejector to a 3rd gen one, and my ejector spring to a new German one (all from HKparts.net), I did not replace these parts. I re-pinched the trigger pack's retention points for the ejector just to be safe. There was no wiggle, but the ejector was still able to spring back and forth freely. I cleaned the heck out of the barrel flutes yet again to ensure that wasn't causing the issue, and since I also have a PTR-91, I took that rifle to the range as well.

    I loaded up some 147 grain ammo, and some more 124 grain, but this time a bit hotter. I went back to the gravel pits and still I was having issues; though it seemed as if they weren't as frequent. When I swapped trigger packs with my PTR, I had issues every couple rounds; I thought this was perhaps due to the rifle hammer spring. When I put the CA89 trigger pack with a 9mm hammer spring into the PTR-91 rifle it did not have a single failure after 40 rounds. I swapped them back and tested again with the 9mm hammer spring in the CA89 and it had same issues. I'm at a loss because I thought I had finally fixed this thing, but I can't isolate the issue at all.

    I just ordered a 100 degree locking piece and another 9mm hammer spring. The locking piece in the gun currently is a number 16. I am going to install the new 9mm hammer spring on the PTR trigger pack, put it in the pistol and I am going to test that to eliminate the trigger pack/ejector lever and spring. Then I'll test the 100 degree locking piece to eliminate the number 16 locking piece. I'm going to buy every type of factory 9mm ammo I can get. After that I'm fresh out of ideas. Worse case, I'm thinking of sending this to an HK certified armorer. Anyone know any that are located near the PNW?



    Keep in mind I change the bolt head to a new RCM one, I am using factory HK magazines (even though I had no issues before with the clear ETS polymer mags)
    Last edited by hatter665; 02-14-2020 at 05:57 AM.

  8. #17
    Gets the Shakes if No HK Contact in 24 Hour Period

    Join Date : Mar 2012
    Location : Mid Atlantic states
    Posts : 704
    Mentioned
    3 Post(s)

    Default

    Look at how the lower fits to the upper, look along the top edge to see if even spacing from front to rear and side to side. If your lower height is off it can cause ejector height issues.

    Turn it over and check through the mag well how the ejector is interacting with underside of bolt. While bolt is closed, press ejector up against underside of bolt, there should be some play. While watching ejector pull bolt rearward making sure ejector is not binding to bottom of bolt, it should be in the channel but not rubbing. Notice how high into channel it is going.

    I suspect (especially with everything you have done)
    You issue is likely to lie in one of 3 areas. (When the parts are to spec and the ammo is quality, it leaves how the parts interact with each other)

    1. Your ejector height may be wrong, too low or too high, if too high will bind bolt or bend ejector (you have pinched things twice to tighten up how the ejector sits according to your posts)

    That is why I want you to look at how your pack sits, you swapping lowers and getting different results reinforces thoughts this could be a contributing factor.

    Thats also why I want you to investigate and watch how the ejector behaves during the cycling process.

    This could be because of denial shelf height or how your lower/pack was set up ( semi cuts of pack, lower denial/lower cut to interact with denial). The spacing between the lower and upper can give an indication, visual observation of ejector may confirm this.

    If ejector height is off the extractor may be dropping the spent casing in the action.

    2. Damaged ejector, damaged or weak spring (do not think is case here. But the extractor must be strong enough to hold casing in place until the ejector strikes the underside rear flinging it. If the extractor cannot hold it, it will drop in action, if the ejector hits casing wrong it will drop it or kick it off but not out.

    3. Your casings might not be clearing your ejection port because of the ejection port. If the reciever is not to spec the casing could actually be bouncing back off the leading edge of the ejection port. Since it does not have this problem all the time and you have improved performance at times by tweaking and swapping parts this may be a "stacking" issue where a few things are just off spec and when those out of spec issues are stacked one on the other the problem shows with a vengeance. When you have checked all the other points, look for scratching, finish damage, and brass marks along the front inside of ejection port, along bottom edge, top edge, etc, to see if any visible evidence of ejecting brass striking it, then degrease the reciever, then take a sharpie marker or some other type of marker or even lipstick and color the areas you suspect that brass might be striking trying to exit the firearm, take some time on range firing it and observe if there is evidence to support that look to see if the brass is wearing off the markings you made.
    Last edited by gulfstategaurd; 02-14-2020 at 03:20 PM.

  9. #18
    Junior Member

    Join Date : Feb 2020
    Posts : 12
    Mentioned
    0 Post(s)

    Default

    Wow!
    You guys are great!
    I love the help and advice you can get here.

  10. #19
    Member
    hatter665's Avatar
    Join Date : Dec 2009
    Location : Seattle, WA
    Posts : 77
    Mentioned
    0 Post(s)

    Default

    gulfstategaurd You're definitely on to something there. I was about to buy an entire new trigger pack, but now I am thinking of a trigger housing and pack. I have carefully watched the interaction of the ejector and the bolt from the magwell before, but I can't seem to find the video I had made on my computer. I took these stills from a different video. When I hold the weapon upside down with the barrel facing away from me and I work the action, I remember I could see the ejector was rubbing on the sides of the channel in the bolt. I am currently out of State attending some training, but as soon as I get home I'll recheck as you said, and make some new videos to upload. I went to my local gun store and checked on their mp5 clones back when I suspected this was the issue, and they kind of did the same in regards to rubbing on the side and how they looked when the bolt was locked to the rear. I moved on to different ideas, but I've always suspected this part of the issue. Do these pics confirm what you were talking about? There is a lot of wear on the ejector, on the underside of the bolt, and all around the ejection port. In case you missed it in my initial post, the original ejector actually broke off at the tip, which to me is a big tell. Do you think getting a whole new trigger housing and trigger pack would fix this? At this point, I'm willing to spend the money since I am probably going to have my tax stamp in the mail when I get home. It's obviously not my go to weapon for anything, I just want it to work so I can have fun with it again.

    I'm actually excited I just broke my ejector on my MP5K PDW Clone...-20180715_093001.jpgI'm actually excited I just broke my ejector on my MP5K PDW Clone...-bolt.jpgI'm actually excited I just broke my ejector on my MP5K PDW Clone...-ca89-ejector.jpgI'm actually excited I just broke my ejector on my MP5K PDW Clone...-ca89-ejector1.jpgI'm actually excited I just broke my ejector on my MP5K PDW Clone...-ca89-ejector2.jpgI'm actually excited I just broke my ejector on my MP5K PDW Clone...-inside-ca89.jpg

  11. #20
    Gets the Shakes if No HK Contact in 24 Hour Period

    Join Date : Mar 2012
    Location : Mid Atlantic states
    Posts : 704
    Mentioned
    3 Post(s)

    Default

    I would say it is more about seeing if the pack needs adjusting first. The pack might be fine but how it interacts with the shelf may need looking at. BUT FIRST VERIFY, it sounds like it might be riding high, from what you have said, past issues.

    That pic of the casing stuck in there looks like beavers chewed the leading top edge where the carrier enters the cocking tube. That has taken some hits but that could just be from casings getting rammed into it thaf failed to eject. I broke out my flat and Navy barrel to mock them up to see if any adjustment may have been made to your ejection port. The angle to the pics makes it hard to tell from the image. One thing I did notice as a reference point, the top right corner of the trunnion is flush with the ejection port edge at that point.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

mp5k ejector

,

will a mp5 eject fired casings with a broken ejector?

Click on a term to search for related topics.