HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function - Page 2
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 23
Like Tree8Likes

Thread: HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function

  1. #11
    HKPRO PREMIUM PARTNER
    jt15550's Avatar
    Join Date : Feb 2013
    Posts : 3,213
    Mentioned
    6 Post(s)

    Default

    Iíve tried the cocking piece backwards and could not get it completely back together, so if you did it mustíve taken some effort.

    Another thing to check, the trigger bar rides on a little spring-loaded plunger in a hole in the bottom of the frame (empty hole in this pic). The bar can fall off during reassembly, but with a punch the plunger can be pushed down and bar moved flush with the frame without taking everything back apart again.



    The plunger:




    Sent from my iPhone using Tapatalk
    01 / 03

  2. #12
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Spring and detent are installed and trigger bar is riding on top...flush with the frame. I didn’t have to work hard to get it back together but still concerned there may be an issue with how the cocking piece is mated up with the hammer strut. When I get back to the house I’ll pull it back apart and get some photos.
    bp1 likes this.

  3. #13
    Unrepentant HKHolic
    TooSixy's Avatar
    Join Date : Sep 2011
    Posts : 18,554
    Mentioned
    221 Post(s)

    Default

    I would double check the Cocking Piece (CP) and make sure it is oriented correctly. As @bp1 has mentioned above, the CP can be installed incorrectly (I managed to do that a couple of times, don't ask me how) and you can notice the issue right away when re-inserting the Sear Axle. It takes a little bit of force to push that Axle back in but everything does go back together; just does not go bang when you pull the trigger.

    Here's a quick snapshot of the CP's position in relation to the LEM hammer.

    bp1 likes this.

  4. Remove Advertisements
    HKPro.com
    Advertisements

  5. #14
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Thanks guys. I'll check the cocking piece orientation.

    Couple of other things:

    1. When I put the pistol back together and rack the slide the trigger moves back in the trigger guard and gets hung up. And when I press it it moves back further and nothing happens.
    2. If I pull the trigger forward, it gets "un-hung up" and I have a DA trigger pull and the hammer travels back and drops. This is my first LEM but that part feels correct.
    3. When I move the slide back to pull out the take down lever the trigger moves back and gets hung up and when I take the slide off I notice the trigger bar is no longer up against the side of the frame. It has moved toward the center of the mag well and is "hung up". I then push the trigger forward and the trigger bar comes loose and moves back to the frame.

    Disassembling now to re-check everything. This is driving me crazy!

    DZ

  6. #15
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    This is the "as removed" orientation of the cocking piece to the LEM hammer. It was installed correctly.

    I also took a couple of photos of it before I removed it. One is with it rotated up as far as it will go (rotated back toward the hammer) and one is rotated all the way down (toward the bottom of the mag well).

    DZ
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4050.jpg HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4049.jpg HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4051.jpg

  7. #16
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Photo of the trigger bar in place on top of the spring loaded detent. Photo of all of the LEM trigger parts that will go back in. Sear complete with GG "long" roll pin installed.

    Also, I installed the GG FPBS last night when I did the first install.
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4054.jpg HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4055.jpg
    Last edited by deltazulu719; 05-26-2019 at 07:09 PM. Reason: updated FBS to FPBS

  8. #17
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Hammer axle, hammer, cocking piece, hammer strut and hammer spring installed. Used the backstrap hole to hold hammer strut in place. Looking down from top hammer strut is in the center groove of the cocking piece and looking at back of hammer the tip of hammer strut is in center of the LEM hammer.
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4057.jpg HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4058.jpg HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4060.jpg

  9. #18
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Well sh$t, I finally figured it out. Everything was installed correctly the first time with the exception of the longer GG pin in the sear. I'm attaching a photo of the factory V1 sear complete which shows the non protruding side of the roll pin was not flush with the opposite side. The LEM sear complete was the same way so I did same with the GG pin. This made it too long and the trigger bar was dragging on the pin and hanging up. I should have seen this out of the gate but I have so much practice now I won't have any problems putting LEM triggers in future HK's (maybe my P30's) if I decide I really like it. Thanks to everyone for all of the input and help!! I really appreciate it.

    Hopefully this thread will help someone out in the future.

    What I can say is the GG short reset on the LEM is "money"!! I'll get to the range this afternoon to test it out.

    DZ
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4065.jpg
    bp1 and Pheenixrizing like this.

  10. #19
    Unrepentant HKHolic
    fatmat27's Avatar
    Join Date : Jul 2009
    Location : Arizona
    Posts : 2,307
    Mentioned
    4 Post(s)

    Default

    Glad you got it all sorted out. Having done a dozen or so LEM kits, I found this problem intriguing.

  11. #20
    Unrepentant HKHolic
    TooSixy's Avatar
    Join Date : Sep 2011
    Posts : 18,554
    Mentioned
    221 Post(s)

    Default

    Quote Originally Posted by deltazulu719 View Post
    Hammer axle, hammer, cocking piece, hammer strut and hammer spring installed. Used the backstrap hole to hold hammer strut in place. Looking down from top hammer strut is in the center groove of the cocking piece and looking at back of hammer the tip of hammer strut is in center of the LEM hammer.
    Your hammer spring is not installed correctly. The roll-pin for the Hammer Spring Block should be in the upper hole (top down) and not the bottom. The bottom hole is for the lanyard roll-pin.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts