HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Like Tree8Likes

Thread: HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function

  1. #1
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function

    Hey Guys,

    I just installed a new LEM trigger kit in my HK45 and at the same time I installed the Grayguns Short Reset system. When I tried function checking the trigger it does not function properly. When I rack the slide it pulled the trigger back in the trigger guard but when I press the trigger it just goes back to the wall and nothing happens.

    Based on what I can tell I think I installed it all correctly but obviously I didn't.

    Any help would be greatly appreciated!

    DZ
    Last edited by deltazulu719; 05-26-2019 at 01:59 PM. Reason: typo

  2. #2
    Senior Member
    MasterJP's Avatar
    Join Date : Nov 2018
    Location : Washington
    Age : 48
    Posts : 172
    Mentioned
    0 Post(s)

    Default

    Hi DZ,

    Did you install the pin that comes with the Grayguns Short Reset kit?

  3. #3
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Yes, I removed the factory sear complete pin and installed the gray guns pin. It protrudes plenty far enough for the GG control latch to actuate it.
    .

  4. Remove Advertisements
    HKPro.com
    Advertisements
     

  5. #4
    HKPRO PREMIUM PARTNER
    jt15550's Avatar
    Join Date : Feb 2013
    Posts : 3,213
    Mentioned
    6 Post(s)

    Default HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function

    Did you put the hammer spring back? Or for that matter, the trigger bar?


    Sent from my iPhone using Tapatalk
    Last edited by jt15550; 05-26-2019 at 11:18 AM.
    01 / 03

  6. #5
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    Trigger bar was never removed and hammer spring is installed. I reused my V1 hammer spring.

  7. #6
    HKPRO PREMIUM PARTNER
    jt15550's Avatar
    Join Date : Feb 2013
    Posts : 3,213
    Mentioned
    6 Post(s)

    Default

    The other common reassembly issue is having the legs of the elbow spring in the correct place, as seen here left of the hammer.




    Sent from my iPhone using Tapatalk

  8. #7
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    here is a shot of mine
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4046.jpg  
    Attached Files Attached Files
    Last edited by deltazulu719; 05-26-2019 at 02:52 PM.

  9. #8
    bp1
    bp1 is online now
    HKPRO PREMIUM PARTNER
    bp1's Avatar
    Join Date : Oct 2018
    Location : USA
    Posts : 282
    Mentioned
    7 Post(s)

    Default

    Quote Originally Posted by deltazulu719 View Post
    Trigger bar was never removed and hammer spring is installed. I reused my V1 hammer spring.
    Is the Hammer Strut in the correct position in relation to the Hammer/Cocking Piece?

  10. #9
    Junior Member

    Join Date : Mar 2016
    Posts : 15
    Mentioned
    0 Post(s)

    Default

    I'm pretty certain it is. Here is a shot from the back. You can see the tip of the hammer strut in relation to the hammer.

    I keep questioning whether it's possible I installed the cocking piece in the wrong orientation but I don't see how it would go together if I had.
    Attached Thumbnails Attached Thumbnails HK45 New LEM Install w/ Grayguns Short Reset Package - Doesn't Function-img_4048.jpg  
    bp1 likes this.

  11. #10
    bp1
    bp1 is online now
    HKPRO PREMIUM PARTNER
    bp1's Avatar
    Join Date : Oct 2018
    Location : USA
    Posts : 282
    Mentioned
    7 Post(s)

    Default

    Quote Originally Posted by deltazulu719 View Post
    I'm pretty certain it is. Here is a shot from the back. You can see the tip of the hammer strut in relation to the hammer.

    I keep questioning whether it's possible I installed the cocking piece in the wrong orientation but I don't see how it would go together if I had.
    I've installed (or tried to, unknowing) install the cocking piece backwards.
    You may have solved the problem.

Page 1 of 3 1 2 3 LastLast

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •