P30SK Issue
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By TahoeNV

Thread: P30SK Issue

  1. #1
    Junior Member

    Join Date : Feb 2017
    Posts : 49
    Mentioned
    0 Post(s)

    Default P30SK Issue

    Good day,

    I took my P30SK V1 LEM to range this morning. This pistol has a couple of hundred trouble-free rounds through it, but this morning, when I would slingshot the slide after inserting a new magazine, it was failing to feed. It would feed fine if I returned the slide to it's closed position prior to putting in a new mag and then racked the slide to load the first round, but would fail every time I would slingshot. Using the same ammo I always do - S&B as well Remington, both ball ammo.

    Any thoughts?

    Thanks
    Last edited by TahoeNV; 06-06-2020 at 06:47 PM.

  2. #2
    Junior Member
    Dwright's Avatar
    Join Date : Dec 2018
    Posts : 44
    Mentioned
    0 Post(s)

    Default

    I had a similar problem with mine when it was new. I ended up filing the magazine feed lips just slightly and then I polished them. I've put 1200 rounds through mine since then without a single malfunction of any kind

  3. #3
    Junior Member

    Join Date : Apr 2020
    Location : Los Angeles
    Posts : 40
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by TahoeNV View Post
    Good day,

    I took my P30SK V1 LEM to range this morning. This pistol has a couple of hundred trouble-free rounds through it, but this morning, when I would slingshot the slide after inserting a new magazine, it was failing to feed. It would feed fine if I returned the slide to it's closed position prior to putting in a new mag and then racked the slide to load the first round, but would fail every time I would slingshot. Using the same ammo I always do - S&B as well Remington, both ball ammo.

    Any thoughts?

    Thanks
    Sounds like a mag issue. Did you try different magazines?


    Sent from my iPhone using Tapatalk

  4. Remove Advertisements
    HKPro.com
    Advertisements
     

  5. #4
    Junior Member

    Join Date : Feb 2017
    Posts : 49
    Mentioned
    0 Post(s)

    Default

    Thanks. I was using only one mag today. That's a good point. If that doesn't solve it, I'll send it back to HK for them to look at it. I don't want to do what Dwright suggested - outside my level of skill!!

    Thanks
    Nintense likes this.

  6. #5
    Gets the Shakes if No HK Contact in 24 Hour Period
    robertp's Avatar
    Join Date : Jan 2016
    Location : Spring Creek, NV
    Age : 66
    Posts : 629
    Mentioned
    4 Post(s)

    Default

    Just a guess but it sounds like a dirty magazine issue. It is amazing what a good magazine cleaning will do. I use a rag and toothbrush.

  7. #6
    Junior Member

    Join Date : Jun 2020
    Posts : 1
    Mentioned
    0 Post(s)

    Default

    Its possible to jam 11 rounds into the 10 round mag. Are you sure you are not doing this?

  8. #7
    rmw
    rmw is offline
    Junior Member

    Join Date : Sep 2018
    Posts : 24
    Mentioned
    0 Post(s)

    Default

    I'm thinking when slingshotting, you may have unintentially slightly ridden the slide down a little. Did you try using the slide release on a loaded mag? I'd guess it probably would have fed.

  9. #8
    Junior Member

    Join Date : Feb 2017
    Posts : 49
    Mentioned
    0 Post(s)

    Default

    Thanks everyone. Mag is clean so I don't think that's it. I'll try a different mag as well as using the slide release instead of slingshotting to see is that helps.

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •