MM23E ejecting problems - Page 2
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
Like Tree3Likes

Thread: MM23E ejecting problems

  1. #11
    Senior Member

    Join Date : Feb 2009
    Posts : 125
    Mentioned
    0 Post(s)

    Default

    I spoke with Mike today, he was a huge help. He said that a 21 ejector wouldnt work and that i needed to use the 21E/23E lever. Im gona swap that out and take it to the range sometime this week and give her another run. On a different note i didnt see nay visible damage to 21 ejector i had in the pack, no cracks or bends.

  2. #12
    Requiescat in Pace
    JTinIN's Avatar
    Join Date : Sep 2002
    Location : Indiana
    Age : 66
    Posts : 2,845
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by Gunfighter1 View Post
    I spoke with Mike today, he was a huge help. He said that a 21 ejector wouldnt work and that i needed to use the 21E/23E lever. Im gona swap that out and take it to the range sometime this week and give her another run. On a different note i didnt see nay visible damage to 21 ejector i had in the pack, no cracks or bends.
    In the long run do yourself a favor and get a second ejector, if you are going to keep the semi pack in the gun, just easier then swapping back and forth.

    Take Care
    John

  3. #13
    Senior Member

    Join Date : Feb 2009
    Posts : 125
    Mentioned
    0 Post(s)

    Default

    I took the mm23e out again this weekend with the 23e ejector that came with the semi pack. Ran about 800 rounds thru it and it ran like a top. Thanks Mike for your help with this and for a great gun!

  4. Remove Advertisements
    HKPro.com
    Advertisements
     

  5. #14
    Supporting Vendor
    rhouston8's Avatar
    Join Date : Apr 2009
    Location : MS
    Posts : 2,020
    Mentioned
    6 Post(s)

    Default

    gunfighter....thx for the feedback. glad you got squared away. i didnt realize the 21 and 21e had different ejector levers prior to this thread.

    hh

  6. #15
    Requiescat in Pace
    JTinIN's Avatar
    Join Date : Sep 2002
    Location : Indiana
    Age : 66
    Posts : 2,845
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by Gunfighter1 View Post
    I took the mm23e out again this weekend with the 23e ejector that came with the semi pack. Ran about 800 rounds thru it and it ran like a top. Thanks Mike for your help with this and for a great gun!
    Looks like you are down the the one remaining problem that Mike can't help you with ..... the ammo surplus running short ;-).

    Good Luck

  7. #16
    Junior Member

    Join Date : Nov 2018
    Posts : 36
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by Gunfighter1 View Post
    I took out my MM23E today for the first time. I ran it with a Lafrance trigger group and 21 ejector. I was shooting MKE Turkish 62 grain 5.56 i linked on saw links. First belt of 100 went like a dream and not a problem. Second belt was not so lucky. Failure to ejects were almost every other round. The rounds would come out of the chamber most of the times but wouldnt eject from the ejection port and get caught in the bolt. A few times it would cycle but the bolt wouldnt close all the way and when i fired it wouldnt fire the round but the hammer would fall. Any body else have any similiar problems or have any suggestions as to what could be the problem. When i put the sear pack in the gun it was hard to get the trigger housing to sit on the shelf and align up. It did feel like it was hitting against the receiver but with a little persusian the stock slid over the grip and i got it closed. Any help is appreciated, i just want to blast away with my new toy. Got all this ammo linked up and nothing to shoot it in.
    I had the exact same problems. What did you do?

  8. #17
    Unrepentant HKHolic
    SudS's Avatar
    Join Date : Jan 2001
    Location : Northern, VA
    Posts : 7,958
    Mentioned
    126 Post(s)

    Default

    Quote Originally Posted by djohns11 View Post
    I had the exact same problems. What did you do?
    The thread is over 7 years old, and the HKPro member you questioned hasn’t been on here in over 6 years, but you never know.
    Lamont and djohns11 like this.

  9. #18
    HKPRO PREMIUM PARTNER
    Lamont's Avatar
    Join Date : Nov 2004
    Posts : 1,189
    Mentioned
    56 Post(s)

    Default

    Quote Originally Posted by SudS View Post
    The thread is over 7 years old, and the HKPro member you questioned hasn’t been on here in over 6 years, but you never know.
    LMAO...
    "We do bad things to bad people".

  10. #19
    HKPRO PREMIUM PARTNER
    Brad4065's Avatar
    Join Date : Dec 2009
    Location : That black SUV in your driveway
    Posts : 3,720
    Mentioned
    56 Post(s)

    Default

    Quote Originally Posted by SudS View Post
    The thread is over 7 years old, and the HKPro member you questioned hasn’t been on here in over 6 years, but you never know.
    So you're telling me there's a chance.

    LOL!!!!!!
    SudS likes this.
    A redneck's famous last words...."Hey everybody, watch this!"

  11. #20
    HKPRO PREMIUM PARTNER

    Join Date : Feb 2004
    Posts : 43
    Mentioned
    0 Post(s)

    Default

    Quote Originally Posted by Brad4065 View Post
    So you're telling me there's a chance.

    LOL!!!!!!
    Sure there's a chance. I was gone for over 6 years once...

Page 2 of 2 FirstFirst 1 2

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

21e trip lever
,
failure to eject mm23e
,
hk trip lever problem
,
mke 62 gr
,
mm23 problems
,
mm23 wont accept my sear pack
,
mm23e ejector
,
mm23e failure to feed
,
mm23e feed problems
,
mm23e issues
,

mm23e problems

,
mm23e trip lever
Click on a term to search for related topics.