10mm Factory Ammo Brass Cracking! Need help - Page 3
Page 3 of 6 FirstFirst 1 2 3 4 5 ... LastLast
Results 21 to 30 of 53
Like Tree6Likes

Thread: 10mm Factory Ammo Brass Cracking! Need help

  1. #21
    HKPRO PREMIUM PARTNER
    kwesi's Avatar
    Join Date : Jun 2007
    Posts : 2,300
    Mentioned
    0 Post(s)

    Default

    SWolff: the Hi LP with Sig has always run great.
    SWolff likes this.

  2. #22
    HKPRO PREMIUM PARTNER
    kwesi's Avatar
    Join Date : Jun 2007
    Posts : 2,300
    Mentioned
    0 Post(s)

    Default

    Update 2: take a look at my ejector:



    Hoping this is and has been the cause of my FTE’s for sometime.

  3. #23
    Unrepentant HKHolic
    SudS's Avatar
    Join Date : Jan 2001
    Location : Northern, VA
    Posts : 7,963
    Mentioned
    126 Post(s)

    Default

    Quote Originally Posted by kwesi View Post
    Update 2: take a look at my ejector:



    Hoping this is and has been the cause of my FTE’s for sometime.
    Unless I’m not looking at that correctly, clone ejector that’s shaped differently than German?

  4. Remove Advertisements
    HKPro.com
    Advertisements
     

  5. #24
    HKPRO PREMIUM PARTNER
    kwesi's Avatar
    Join Date : Jun 2007
    Posts : 2,300
    Mentioned
    0 Post(s)

    Default

    Suds: HK German Ejector

  6. #25
    HKPRO PREMIUM PARTNER
    kwesi's Avatar
    Join Date : Jun 2007
    Posts : 2,300
    Mentioned
    0 Post(s)

    Default

    Suds: it’s the left (backside) of the ejector that has rubbed something. The side engaging the case is worn as I’ve come to expect in the 10mm.

  7. #26
    Unrepentant HKHolic
    SudS's Avatar
    Join Date : Jan 2001
    Location : Northern, VA
    Posts : 7,963
    Mentioned
    126 Post(s)

    Default

    Quote Originally Posted by kwesi View Post
    Suds: it’s the left (backside) of the ejector that has rubbed something. The side engaging the case is worn as I’ve come to expect in the 10mm.
    Rubbed something or hammered something?

  8. #27
    HKPRO PREMIUM PARTNER
    kwesi's Avatar
    Join Date : Jun 2007
    Posts : 2,300
    Mentioned
    0 Post(s)

    Default

    I loaded 4 S&B rounds then hand cycled. COAL did not decrease. If setback had occurred it might have explained the split cases.

  9. #28
    Supporting Vendor

    Join Date : Apr 2002
    Posts : 1,245
    Mentioned
    34 Post(s)

    Default

    I think it is just a bad lot of ammo.
    That ejector is not good.
    SW/Cohaire recs. are not spec.
    Looks like bolt group alignment to trigger pack alignment issues.
    Something is whacking the ejector bad.
    FTE issue not case splitting related.
    MM

  10. #29
    Unrepentant HKHolic
    SudS's Avatar
    Join Date : Jan 2001
    Location : Northern, VA
    Posts : 7,963
    Mentioned
    126 Post(s)

    Default

    Quote Originally Posted by hk21man View Post
    I think it is just a bad lot of ammo.
    That ejector is not good.
    SW/Cohaire recs. are not spec.
    Looks like bolt group alignment to trigger pack alignment issues.
    Something is whacking the ejector bad.
    FTE issue not case splitting related.
    MM
    I'm with Mike on this one. Thinking you have more than one thing going on here (maybe three).

  11. #30
    HKPRO PREMIUM PARTNER
    Player_To_Be_Named...'s Avatar
    Join Date : Nov 2012
    Location : Sunny, sunny O-H-I-O
    Age : 62
    Posts : 1,444
    Mentioned
    6 Post(s)

    Default

    I have 275 rounds of S&B 180 gr 10mm through one of Mike's guns. No issues whatsoever. Lot number appears to be "60 / 29" as stamped on the end flap.
    NRA Benefactor Member
    NFATCA Member

Page 3 of 6 FirstFirst 1 2 3 4 5 ... LastLast

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •