3 Lug device didn't fit on SP5 - Page 2
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: 3 Lug device didn't fit on SP5

  1. #11
    HK JUNKIE
    Keith120286's Avatar
    Join Date : Oct 2016
    Location : Central Texas/Western Colorado
    Age : 33
    Posts : 771
    Mentioned
    12 Post(s)

    Default

    Quote Originally Posted by soviet64 View Post
    Can someone with the AAC Ti-RANT TRIAD adapter please also report here. Thank you!
    Interested in this myself.
    WTB: HK94 (IG preferably)
    WTB: SP89 (IK only)

  2. #12
    HKPRO PREMIUM PARTNER
    HkCHUCK's Avatar
    Join Date : Nov 2001
    Location : NE Ohio
    Posts : 1,048
    Mentioned
    16 Post(s)

    Default

    I am not familiar with the Angstadt muzzle device so maybe my question is not germane.

    Is it possible that the muzzle device is rubbing up against the dust cap? I have encountered that
    problem on occasion. Try mounting the muzzle device after removing the dust cap and see it it works.

    Chuck

  3. #13
    Unrepentant HKHolic
    SudS's Avatar
    Join Date : Jan 2001
    Location : Northern, VA
    Posts : 7,934
    Mentioned
    126 Post(s)

    Default

    Quote Originally Posted by Sean73Hk View Post
    When I asked them about it, they said HK has changed the lug dimensions slightly compared to the older barrels they tested with.
    This statement would be my biggest suspicion that the problem IS the muzzle device.

Page 2 of 2 FirstFirst 1 2

Sponsored Links

 
 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •