HKPRO Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello all, I have a question regarding a CA94 I recently picked up. I brought it to the range and began to fire a magazine of Winchester 124 gr ammo. Anyway, toward the end of the string I pulled the trigger and the round fired, I got a flash out of the ejection port and felt a little heat on my forehead. Like a bonehead I tried to continue but no rounds would fire after that. I would pull the trigger and nothing would happen. I recovered all the empty casings and saw no evidence of a case failure. I tried a new magazine loaded with Speer lawman frangible and nothing would fire so I moved on to other guns. I got the gun home took it apart and I didn't see any damage. I checked bolt gap which was .016. I am new to these roller lock guns so I was looking for any suggestions as to what may be a problem with the gun. Thanks.

Mike
 

·
Registered
Joined
·
1,008 Posts
Give us some more detail. Were you seeing primer strikes on the unfired rounds? Did you completely disassemble the bolt group? Just wondering if you have a broken firing pin.

Best,

TC
 

·
Registered
Joined
·
1,274 Posts
Better yet, disassemble your bolt group, take some close up pics and post for us to review.

BTW, does your trigger pack function OK? Cock the hammer, pull the trigger and the hammer drops?
 

·
Premium Member
Joined
·
3,410 Posts
beachpatrol.
definately need more details. How well do you know your way around these roller locks?
Dj
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I will try some pictures later today. I'm a Glock and a Colt M16 armorer but they are way easier to work on than these roller lock guns. Anyway, light primer strikes on the ammo firing pin appears ok.
 
1 - 5 of 5 Posts
Top