HKPRO Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,

I just picked up my CA-94 MP-5 clone and need some help with the rear sight.

The rear sight drum on my new never fired ca94 spins freely either way, and does not lock into place anywhere. It does not set, it just spins freely.

Can someone give me any recomendations on how to resolve this, or do I have to send it back to the manufacturer?

Any help is greatly appreciated.

Thanks
 

·
Registered
Joined
·
626 Posts
I read about another person having the same issue over on ar15.com. he called cohaire, or whatever incantation they are now, and apparently todd was very helpful and talked him thru a fix.

If I remember correctly it was just some stuff that was stuck in the site assembly.

I'd flush it with some brake cleaner, non chlorinated, and let it soak in penetrating oil overnight.
 

·
Registered
Joined
·
2,937 Posts
There is a small ball bearing that allows the drum to click into place.

Sounds to me like the ball bearing is gone or is so full of gunk that the spring isnt pushing it up against the drum.

Either way this is the kind of stupid crap that companies that make clones miss. Except for Vector.

I have a Vector and a Cohaire. The Vector worked fine out of the box the Cohaire took a hell of a lot of tweaking before I got it up to snuff.
 

·
Registered
Joined
·
217 Posts
The detent must not be enough to hold the sight drum down. It probably needs cleaning, also if it's prepainted, then the paint may have covered up the depressed area. You may have to take the sight drum assembly apart and clean it out.
 
1 - 4 of 4 Posts
Top