HKPRO Forums banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
2,335 Posts
Discussion Starter #1 (Edited)
While firing my CA89-10 I experienced the bolt and carrier frozen. I had to pound it out with a wood dowel only to find the tip of the left leg had chipped off. This is the Coharie carrier:
 

·
Registered
Joined
·
1,733 Posts
Did you check your receiver for roller marks? I am wondering if the rollers extended out at the wrong time.
 

·
The Librarian
MP5-N and HK23E-K
Joined
·
5,585 Posts
That's disappointing, but in-line with expectations with a non-German part. Hopefully you got a few thousand rounds out of it.
 

·
Premium Member
Joined
·
2,335 Posts
Discussion Starter #7
Did you check your receiver for roller marks? I am wondering if the rollers extended out at the wrong time.
I had a roller mark ( near chamber ) on the same side shortly after purchasing over 2500 rounds ago. I did notice a tiny roller mark on the other side near the middle of the receiver. Not sure it it is new.
 

·
Premium Member
Joined
·
2,335 Posts
Discussion Starter #8
That's disappointing, but in-line with expectations with a non-German part. Hopefully you got a few thousand rounds out of it.

I believe this is one of TB's cast carriers. I have about 3,200 down the pipe.
 

·
Premium Member
Joined
·
2,335 Posts
Discussion Starter #9
TPM Outfitters did such a stellar job fixing my Vector 53K that I'm going to visit with Ken and Matt and have them go over this and see what they recommend. It was very problamatic when purchased. I got it running 100% for the past 200 rounds until this failure. I expect they will bring it back into spec whatever is needed. I've had to run -6 rollers.
 
1 - 9 of 9 Posts
Top