HKPRO Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I recently bought one of these rails after being told it would work on my 53 (Urbach conversion). It fits fine on the receiver and each edge on the right side is just right at the ends of the ejection port.

However, no matter how much I tighten the hex screws down, after a few rounds the rail begins to "slide" back such that the "front" end of the rail begins to overlap the ejection port by as much as 1/2".

Has anyone had this problem and how do you fix it. Or maybe the question is, is this really the right rail for a 53.

Any help appreciated, thanks
 

·
Registered
Joined
·
555 Posts
Since I have no pic of how you tried it I will take a guess.
I think you have it on backwards. I have the same mount and it is reversible between the MP-5 and the 5.56/7.62. The front end that slides back over the ejection port the way you tried it should be on the left side of the receiver. The tab that sticks up on the rear receiver pad locks into the cutout on the bottom of your mount so that there is no way it could move back.
Good luck and be careful not to over tighten those small mounting screws, I have read that they bust very easily.
 

·
Registered
Joined
·
532 Posts
Does yours look like this?



This is a B&T212621 like you mention, and it sits thusly to allow installation. HTH,
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Well doh! Thanks for the pic and the answer. I just assumed what I thought was the gap for the ejection port was just that, so I put it on accordingly. Doof boy here had it on backwards!
 

·
Registered
Joined
·
532 Posts
It's easy to attempt, esp. since it's designed to be 'universal' and swap over the MP5's. Glad you got it lined up,
 
1 - 5 of 5 Posts
Top