HKPRO Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter #1
I have several of the Korean 9mm MP5 mags (both generations), and my full size gun runs fine with them. No hiccups whatsoever. But when I run them in my K, I occasionally get some feeding issues. With the HK mags, it runs fine. I'm wondering, since the K has a faster cycle rate, could the problem be with the magazine spring? Has anybody had similiar issues and replaced the with HK springs and the problem been fixed?
 

·
Registered
Joined
·
536 Posts
It more then likely has to do with the feed lips on the mag itself. When you couple the feed lip problem with the reduced recoil spring of the "K", it can cause issues. At least it has for me... My clone also had issues with the mag catch which causes issues but I've fixed most if it.

Good luck!
 

·
Registered
Joined
·
419 Posts
It more then likely has to do with the feed lips on the mag itself. When you couple the feed lip problem with the reduced recoil spring of the "K", it can cause issues. At least it has for me... My clone also had issues with the mag catch which causes issues but I've fixed most if it.

Good luck!
How did you fix the mag catch issues if I may ask. I have 5 Korean mags I'd love to be able to use in my K clone.
 

·
Registered
Joined
·
571 Posts
i installed Wolff high power springs in my Korean mags, to use in my K-length MKE.

it helped for a while but did not completely solve the problem. the straight mags work better and i don't shoot hollow points, anyway
 

·
Premium Member
Joined
·
3,410 Posts
hk94dude,
it could be the body, spring, follower &/or any combination there of. Swap over the spring, then test. If that doesn't make a difference then also swap over the follower & test. Noting differences (if any) with each change. That way you can see if the problem follows the spring, follower or the body.
Dj
 
1 - 5 of 5 Posts
Top