HKPRO Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm trying to install a hybrid LEM trigger onto a 9mm USP Expert, and I've run into some trouble.

After reinstalling all of the parts, the hammer won't release when I pull the trigger all the way back. If I pull the trigger all the way back, it just sits there at the rearmost position until I let the trigger back out, and then it goes back to resting position.

I believe the hammer strut is disengaging from the cocking piece, but I'm not sure why. When I reassemble the firearm I make sure that the strut does engage the cocking piece (I can see the rear tip) and reinstall the hammer spring and lanyard loop to make sure it stays there. If I pull the trigger with the slide off, I get a very heavy pull but it does drop - I catch the hammer before it impacts anything.

I have the nub of the cocking piece against the left side of the hammer, and the notch for the strut faces down. The cocking piece spring sits with a leg against the hammer and the other leg against the back of the sear. I do make sure the hammer doesn't come back when I am inserting the disconnector and control latch and catch. The control latch's hook is going over the hammer axle.

Any ideas?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I apparently resolved the main issue - I can get the hammer to drop - but the trigger bar appears to be getting hung up after the drop and the trigger won't reset on its own. If I push it forward, that resets things, and if I give the trigger bar a little lateral push then it resets. There's a little bit of rattle with the trigger bar, almost as though it needs a spacer or a washer there, though I don't see anything in the instructions about requiring a spacer nor was one included in the kit.
 

·
Registered
Joined
·
2,924 Posts
Personally, I would remove the parts and start again from the beginning while watching step by step against SkullBox's video tutorial and TooSixy's Tutorials.
Make certain you installed the new parts and did not put back one of the stock parts like the original hammer. The install/swap is really straight forward, so it sounds like something went in wrong or wasn't swapped out.
 

·
Registered
Joined
·
18,641 Posts
Did you try backing in the stop screw on the trigger itself? That would resolve the main problem you're having.

The other issue with trigger not resetting correctly, what TRS did you use? Match TRS or Light TRS?
 

·
Registered
Joined
·
228 Posts
I apparently resolved the main issue - I can get the hammer to drop - but the trigger bar appears to be getting hung up after the drop and the trigger won't reset on its own. If I push it forward, that resets things, and if I give the trigger bar a little lateral push then it resets. There's a little bit of rattle with the trigger bar, almost as though it needs a spacer or a washer there, though I don't see anything in the instructions about requiring a spacer nor was one included in the kit.
Just speculating, but make sure the trigger bar is riding on top of the trigger bar detent. It can slip off of that very easily during re-assembly, which I think would affect the trigger resetting. The trigger bar isn't going to be perfectly rock-solid - it will have some wiggle normally - but there shouldn't be so much space in between the frame and the trigger bar that it would look like it needs a washer.
 
1 - 9 of 9 Posts
Top