HKPRO Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Did a quick search but coudn't find something similar to my problem. Am using a Coharie MP5K/40. changed bolt, ejector, extractor,trigger group to HK german. using RCM as bolt carrier. problem arises after firing a few rounds. extractor spring tilts out of the extractor until it loosens. tried installing it again and after a few rounds it tilts again until it loosens. extractor spring is new bought from hkparts.net. Installed an hk rifle extractor spring but bolt won't go into battery when chambering a round. I analyzed that extractor was too stiff to move. has anyone experienced this type of problem. thanks.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3




as you can see in the pics the extractor spring slightly tilts to the right. after a couple of rounds it dislodges/loosens from the extractor.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I also observed that the 40cal extractor spring has a slight bend at the end of the spring while the rifle extractor spring is just straight to the end.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
i tested the gun this afternoon. i installed the rifle extractor spring. manually placed a round inside the chamber and slapped the charging handle. bolt goes into battery. but when trying to chamber a round from a magazine it won't go into battery.

also tried placing a round manually in the chamber and slapping the charging handle. then inserting a loaded magazine. pulling the trigger the gun cycles properly with the rifle extractor spring not tilting. what do you think is the problem? action spring weak? not enough to force the extractor to claw a round?
 

·
Premium Member
Joined
·
1,164 Posts
fireboy

Just a suggestion, and I assume that the extractor itself is a Hk German one, have you tried bending the tip or your .40 cal extractor spring?
From the pics it seems like the extractor is not down in the extractor enough to keep it from working out. Maybe the loop of the extractor sping
will not fit down in the extractor and that maybe why it is working its way out ?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
fireboy

Just a suggestion, and I assume that the extractor itself is a Hk German one, have you tried bending the tip or your .40 cal extractor spring?
From the pics it seems like the extractor is not down in the extractor enough to keep it from working out. Maybe the loop of the extractor sping
will not fit down in the extractor and that maybe why it is working its way out ?
good suggestion hkchuck will try it. thank you very much
 

·
Registered
Joined
·
24 Posts
Yeah, from looking at the pics it kinda looks like the spring isn't sitting down in the extractor far enough. It's hard to tell because it's already twisted, but it really doesn't look like it fits right. It should be down in there far enough that it can't twist around like that. Good luck with it and make sure and let us know how it works out.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
bended the spring, still tilts out after a few rounds. i think the spring has a defect because there is a very very slight twist at the end portion of the spring. might just order a new set of springs from adam. anyway thanks for the suggestion.
 

·
Registered
Joined
·
13 Posts
yea...looks like the spring has a defect, there should be no twist at the end portion of the spring, I also agree that even though it is dislodged in the photos that it still doesnt appear to fit right.
 
1 - 12 of 12 Posts
Top