HKPRO Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
Gun has always run like a top till just the other day when i took the timed hammer out and put the regular hammer in it for use in the 51, got done with the 51 and put the timmed hammer back in pack and put it in the SP89 again. Immediatly the 89 would only run about 3 or 4 rnds full auto then stop, pull bolt back and it fed a round and has a light primer strike.

Never had to shim the pack before but i shimmed it now and when i run it now it goes about 17 rnds threw each mag the first 10 rnds or so runing real smooth then the last 7 rnds or so it gets choppy??? sounds like a car with one plug wire disconnected then it quits and once again it has a rnd fed in chamber and light primer strike?

Using HK ejector, HK parts all the way around except the timmed hammer from HKparts.net.

Any clues? Dont think i can shim it anymore then it is.
 

·
HK Shooting Team
Joined
·
2,798 Posts
why did you change the hammer in the 1st place? how high does the ejector lever sit in the bolt head......look when you pull bolt to rear and see where ejector lever sits......it should fill the space it fits into
 

·
Registered
Joined
·
180 Posts
Discussion Starter #4
Ejector lever is in the designated groove, its not havin problems ejecting, the rnd thats left in the chamber with light primer strike is a UN fired rnd everytime. What would make it run smooth 1/2 way threw the mag then all of a sudden run erratic (Spelled right?) then leave a live rnd in chamber? Sounds like timing or headspace to me but the bolt gap looks good?
 

·
HK Shooting Team
Joined
·
2,798 Posts
ejector lever height is a good check for the need of the shim.......did you check your firing pin spring? Is the channel in the bolt carrier where the locking piece and firing pin fit gunked up?
 

·
Registered
Joined
·
20 Posts
I know this is a really old thread, but its worth a try...

Did you ever figure out what the problem was? I am experiencing a similar problem. RDTS 4 position pack on a DJ Getz reverse stretch clone. Pack fits nice and tight. Things run well for X # of rounds in a mag, then it stops. When I cycle the gun a bullet with a light primer strike comes out. I've tried multiple HK mags and 3 different types of ammo
 

·
Registered
Joined
·
20 Posts
Just in case someone finds this in a search years from now: I replaced my hammer spring with an enhanced version from hkparts and replaced the firing pin. On close inspection it looks like the surface that is struck by the trigger pack hammer arm had "mushroomed" a bit on the firing pin ... perhaps from the increase in force from using a rifle spring instead of a 9mm spring?

I haven't been to the range to test this out yet. I'll try it out this weekend and report back for reference.
 

·
Registered
Joined
·
20 Posts
It was the trigger pack after all. Ralph from RDTS said that the "Hammer welds" were broken. I got the repaired pack back yesterday and hope to try it out this week.
 

·
Vendor
Joined
·
2,037 Posts
Broken hammer welds. Haven't heard/seen that one. Man I wish we had before & after pics. Regardless ..,thanks for the follow up.
 
1 - 12 of 12 Posts
Top