HKPRO Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,343 Posts
Discussion Starter #1
So my A grade P7 is doing something weird. When I pull the slide back it wont lock with a empty mag in. Or sometimes it will lock back but I have to hit the rear of the slide to make it go back to normal. It also won't release the slide when I squeeze the lever. However this usually only happens when I am physically trying to do it. I just took it out and tried both of my mags. When I actually shoot the gun the P7 seems to work right, but it just feels like something is off a bit. And the cocking lever seems to have a little more play in it then usual. I did research past posts on this topic and from what I can gather is it the Rocker spring. And if so is this a hard fix. Also I cleaned it very well and am almost positive a dirty gas tube is not causing any of these issues. Thanx for any advise or consderation.
 

·
Registered
Joined
·
1,079 Posts
Did these problems show up after the last cleaning? If so, some crud might have got in the works. If not, hopefully a P7 pro will be by to truly answer your question.

Good Luck!
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter #3
Did these problems show up after the last cleaning? If so, some crud might have got in the works. If not, hopefully a P7 pro will be by to truly answer your question.

Good Luck!
No it started awhile back but has gotten progressively worse. Deep cleaning doesn't seem to help.
 

·
Registered
Joined
·
3,250 Posts
Slide failure to lock open-

-Weak or broken magazine spring. Replace magazine spring.
-Weak or broken slide release or slide release spring. Replace release/spring.
-Magazine follower fouled. Clean magazine.

Slide failure to snap forward when cocking lever is depressed-

-Unhinged, broken or weak slide release spring. Replace slide release spring.

Sounds like both your issues can be associated with the slide release and it's spring. Start by checking those two parts.
 

·
Premium Member
Joined
·
3,807 Posts
If you have cleaned the gas cylinder well with both scrapping tool and brush then the issue lies under the grip panel (left side). Did you remove that during cleaning? Did you use a toothbrush to scrub the parts under the grip panel? Did the panel get installed corectly after cleaning - meaning flush with the frame all the way around and the front upper tip flush with the frame? It is possible when you cleaned underneath with the brush if you did you inadvertanly disengaged the rocker spring from the rocker or the flat headed pin that holds the rocker and slide stop lever in place is up and not fully seated. Press it down to fully seat it once the rocker spring is in the correct position. Reference the P7 armorers manual to see where it should go or maybe one of the folks here can post a photo of the left and right sides of the P7 fram under the grip panels for reference where the parts should be when in the correct position and how the grips fit flush when properly positioned.

In the P7 there are various parts that perform numerous operations. If you disturb one part it can effect both the magazine catch/release and slide lock.

G3Kurz
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter #7
Thanks for the detailed reply, and it would be awesome if someone could post that pic.
 
1 - 9 of 9 Posts
Top