HKPRO Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
628 Posts
Discussion Starter · #1 ·
just got my cohaire .40 clone, and the rear site just spins. it felt like there was a little detent in there, stopping it at the various apetures sometimes, but it doesnt have any resistance anymore.

anybody have a quick and easy fix?

I tried lubing it real good, as well as flushing it with brake cleaner, but nothing seems to work.

any help would be greatly appreciated.

ps---
this thing actually works! it doesnt like reloads very much, but the wwb, umc, and wolf that they say not to use work fine. no stoppages with new ammo. Im also guessing any of the reload issues will be solved with use of genuine HK mags.
 

·
Registered
Joined
·
242 Posts
just got my cohaire .40 clone, and the rear site just spins. it felt like there was a little detent in there, stopping it at the various apetures sometimes, but it doesnt have any resistance anymore.

anybody have a quick and easy fix?

I tried lubing it real good, as well as flushing it with brake cleaner, but nothing seems to work.

any help would be greatly appreciated.

ps---
this thing actually works! it doesnt like reloads very much, but the wwb, umc, and wolf that they say not to use work fine. no stoppages with new ammo. Im also guessing any of the reload issues will be solved with use of genuine HK mags.
My take on it is to try to remove the sight and check to see if the spring that loads the detent ball isn't broken or in a bind. Just be careful no to loose any parts when you disassemble it.
 
1 - 2 of 2 Posts
Top