HKPRO Forums banner

1 - 20 of 83 Posts

·
Premium Member
Joined
·
66 Posts
Discussion Starter #1
So I think I might have had my first squib failure. Unfortunately, it was in my T36C the first time out with the suppressor. I've only had about 500 or so rounds through it since I got it and I love it! Took it out on Saturday with the suppressor for the first time (AAC 556SD) and about 10 rounds into it the backplate blew off and destroyed part of the stock. The receiver looks okay, but a section of the bolt carrier appears to have lost a small chunk of metal where the bolt head pivot lock is on the carrier. I've already been in contact with Tom as I didn't think it about it being the result of a squib since there was no bullet in the barrel. I was using Federal American Eagle 55Gr (same stuff I've used through it since day one). I let that manufacturer know as well. Here's some pics that I also sent Tom.

20200904_195701362_iOS.jpg 20200904_195709829_iOS.jpg

20200904_195718284_iOS.jpg 20200904_195724905_iOS.jpg

20200905_004223551_iOS.jpg 20200905_004311385_iOS.jpg

20200905_004400026_iOS.jpg 20200905_004458303_iOS.jpg
 

·
Registered
Joined
·
1,175 Posts
Wow.

That is ugly looking damage.

The stock and buffer are cheap to replace.The Bolt Carrier is toast, and those are a bit of money.

Could have been worse, and since you didn't get hurt that is all that matters in the end.

Crazy incident!
 

·
Registered
Joined
·
2,863 Posts
Wow, glad you are ok. Send it back to Tom for an in-depth inspection and post repair function check to be sure.
 
  • Like
Reactions: NewDefSys

·
Premium Member
Joined
·
182 Posts
I’m glad you’re okay. Please do let us know the inspection results. I would definitely want to be aware of anything that might have caused that level of destruction.
 

·
Registered
Joined
·
15 Posts
Wow, sorry that happened and glad you’re alright. Tom is a stand up dude and will get you taken care of.
 

·
Premium Member
Joined
·
66 Posts
Discussion Starter #10
Ok, but what makes you think that a squibb round caused this, did you notice a round not sounding normal before this happened? This looks, to me anyway, to be an out of battery firing from what I'm hearing and seeing.
I did not, but between hearing protection and the can and others shooting I can't rule it out. Based on the pics I sent to Tom, he thinks it's most definitely a squib. Specifically he thinks that it had a stoppage before the gas system since it appears to be okay as well.
 

·
Registered
Joined
·
2,863 Posts
That receiver looks ok, what about pics of and down the bore of the barrel?
 

·
Sheepdog in West Texas
Joined
·
1,755 Posts
I'm SURE that RoundelNut599 is basically glad he's not in the hospital right now with tubes attached to places you do not normally want tubes attached to.

And I'm also fairly confident with Tom being able to fix that. But let's let Tom inspect it and give us his opinion.

Again, RN, you did dodge a bullet as it were.

Take care.
 

·
Registered
Joined
·
363 Posts
I’m just glad the OP is ok.
 

·
Registered
Joined
·
119 Posts
So the gun did not cycle on the squib round...? Usually squibs dont cycle so you manually charge and then boom...
 

·
Premium Member
Joined
·
66 Posts
Discussion Starter #20
So the gun did not cycle on the squib round...? Usually squibs dont cycle so you manually charge and then boom...
I'm not sure what happened. I had no malfunctions, so no manual charging or clearing of any type. I shot 15 rounds out of one G36 mag so I could compare against putting the can on it. Dropped the mag, put the can on, inserted second mag with 15 rounds and charged it. Shot either 9 or 10 suppressed and on the next one....boom. One thing I did notice after a few shots suppressed is that the clear G36 mag was fogging up. On a direct blowback I know that can happen, but should I have seen that with gas system on the G36? I really didn't think much about it at the time and I'm not sure it's necessarily a precursor to an issue or not. To be honest, I'm not convinced it's a squib. I've seen a few and they happened exactly as you described. Some malfunction resulting in a clear and charge and then boom. I'm hoping Tom's inspection will shed some light on it.
 
1 - 20 of 83 Posts
Top