HKPRO Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,
I have had my POF for about a year, have fired around 750 rds through it without any issues. The last two times shooting it, it seems as if it will fire 3-4 rds, will eject and cycle a new one, then when I pull the trigger, I hear nothing. There is no indent of a primer strike on the cartridge. If I eject that one, it will fire a few more before doing it again. I have a HK navy trigger pack on the gun but it's been there since I bought it. This did start when I started shooting suppressed. Also, I've noticed what looks like metal shavings all over the internals after shooting. Any suggestions or names of who I could send it to for repair?
Thanks
 

·
Premium Member
Joined
·
2,461 Posts
Have you field stripped the gun and inspected it? Looked for problems? Has it been cleaned recently? What material are the shavings made of? Brass? Steel?
Remove the bolt head and inspect the firing pin and spring. Be sure there isn't anything in the bolt head that can block the firing pin and that the pin and spring are not broken. Broken spring and pin pieces can impede the firing pin as can shavings from an external to the bolt group source.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Field stripped it, couldn't find any areas that looked worn or would be creating the steel shavings. Bolt was dirty but firing pin and spring looked fine. I really have no clue where these shavings are coming from. I gave it a good cleaning after the first time it did this and took it back today, same issues occurred.
 

·
Banned
Joined
·
2,011 Posts
Have you field stripped the gun and inspected it? Looked for problems? Has it been cleaned recently? What material are the shavings made of? Brass? Steel?
Remove the bolt head and inspect the firing pin and spring. Be sure there isn't anything in the bolt head that can block the firing pin and that the pin and spring are not broken. Broken spring and pin pieces can impede the firing pin as can shavings from an external to the bolt group source.
God I love your signature line!!

I love when guys cry about Government knowing what they own then they list it for everyone to see!! Gotta compare C**K size or Maybe it's Bank Acct balance..??

Co-Witness, Bwahahahahah!!!
 

·
Premium Member
Joined
·
2,461 Posts
Steel shavings have to be coming from somewhere and one would think the area would be obvious.

At any rate, when the problem occurs have you pulled the stock and lower to see if the hammer followed? This could be occurring and the cause be in the trigger pack. If you have another trigger pack you could swap it into the gun and test it, that would confirm or eliminate that item for the cause. If you don't have another pack or don't know how to properly install one I suggest simply sending the gun to one of the well known HK gurus here on the boards. They'll find the cause in a jiffy.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I've used all brass case 147gr and 115gr ammunition. The trigger pack works without issue when removed from the gun. I have another trigger group I'm going to swap out and try later in the week to see if that is where the issue is. What are the names of some of the builders on the site that would be willing to take a look at it, in case I'm unable to find the problem.
 
1 - 8 of 8 Posts
Top