HKPRO Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey gents,
I had my usc turned into a ump about a year ago. It was working flawlessly untill recently it started misfiring. When I physically chamber a round. It will fire and extract and chamber a new round and all that good stuff, but the next round is always a light strike. I have switched up magazines and ammo and still keep running into the same problem. Has this been an issue for any one else? If so, how did you fix it?
 

·
Registered
Joined
·
121 Posts
When you say you can physically chamber a round and it fires fine, do you mean you place the round in the chamber yourself (not from the magazine)?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
By physically I mean when I charge it with the lever. It's when a round is chambered from the recoil that I have an issue with the light strikes
 

·
Registered
Joined
·
121 Posts
Also, I know you said you have changed ammo, can you provide some details what kind you have fired?
 

·
Registered
Joined
·
312 Posts
Have you cleaned it? Particularly the bolt/firing pin channel?
Have you dropped the lower and inspected the fcg for anything that looks broken or damaged?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Yes the firing pin is striking the primer but just not enough to set it off. I have shot a lot of reloaded rounds from two brothers armory out of Florida and didn't have any issues. Once I started running into this problem I switch to some new Black Hill Ammo and still had the same problem. I have pulled my bolt apart multiple times to see if I could find anything wrong but I don't see anything that would cause this problem. I have cleaned it and I have checked my lower and didn't see anything out of place. But I'm not a gunsmith.
 

·
Registered
Joined
·
312 Posts
Just to clarify - it fires EVERY TIME you manually cycle the bolt? Not sometimes, not most of the time, but ALWAYS?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Yes every time I manually cycle the bolt it fires. The misfire presents its self on the second shot when the bolt is cycled from the recoil
 

·
Registered
Joined
·
134 Posts
Pics of your internals and bolt?

Sent from my KFJWI using Tapatalk HD
 

·
Registered
Joined
·
312 Posts
Pictures should help.

From a logical standpoint, unless the bolt was short-stroking and not fully cocking the hammer, I can't see how there would be a difference to the FCG, unless the hammer was getting hung up on something.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
its not letting my upload pictures from my phone so I'll get the pictures on here tonight when I get to a computer
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
That's what I don't get. And the hammer shouldn't be getting caught on anything because it would get caught on the first round also
 

·
Registered
Joined
·
312 Posts
Can you get a shot of the inside of the receiver and the chamber?
Is the bolt fully in battery when it's light striking?
 
1 - 18 of 18 Posts
Top