HKPRO Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
Hey, kids.
I'm in need of a little help here. This afternoon I picked up a used USP compact, V1. I like the LEM, so I installed the factory kit. It's all done, and works as intended, but I noticed what might be an anomaly.

Pull the trigger, hammer drops, all is good. But on the reset, the trigger bar slips off the spring plunger, and moves to the left. The gun has been doing this, as I can see wear on the side of the plunger. Is it supposed to do this? It seems that the trigger bar should travel straight back, staying on top of the spring plunger.

Please advise.

Thank you!
Rob
 

·
Registered
Joined
·
87 Posts
If I recall correctly the trigger bar should be captured in a notch on the hammer axle that holds it over the plunger.
 

·
Registered
Joined
·
216 Posts
Discussion Starter #3
Thanks, Mark. That is indeed the case, but the tolerances a a bit sloppy. After a couple times disassembling and reassembling, as I worked on other parts of the gun, the trigger bar stays in place. Still, it's not so perfect that it travels in a straight line--the bar deflects to the left a little when the trigger is completely pulled. My P2000SK does exactly the same thing. There are about 7-8 years between the guns, so I'm sure this isn't an uncommon trait on HK pistols of this design. I'm done being concerned about this, but if anyone has seen this phenomenon before and knows what's up, I'll be watching this thread. Thanks again.
 
1 - 3 of 3 Posts
Top