HKPRO Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've done a bunch of searching around the forums and haven't found anything regarding this problem.

I have a USP40 that I often shoot with a 9mm barrel installed. I mainly shoot steal plate challenges with it. It's a1994 (KE) that I have installed a match trigger kit in. I also updated the hammer strut and control latch when I installed the match trigger kit.
Everything worked fine for aprox 2000 rounds. Now suddenly the hammer intermittently doesn't remain cocked after firing. About 50% of the time, after firing a shot, the hammer will be down and the pistol will be in a double action mode.
Dry firing the pistol and manually cocking the pistol does not replicate the problem. Cocking the hammer manually acts normal. Pushing on the hammer after cocking does not make it fall. I have every indication that the sear engagement is solid once the hammer is cocked.

Any thoughts?



Thanks in advance for any thoughts or ideas.


akspudus
 

·
Registered
Joined
·
18,643 Posts
There have been a few posts about this same issue over the years. I would check the flat sear spring and make sure it is not broken or out of spec. A visual inspection of the sear also helps.
 

·
Registered
Joined
·
4 Posts
Hi akspudus,

After 11-12K rounds, my HK45 did that same thing. Took it apart and a piece of the flat spring came out - it was broken in half.
Ordered one from hkparts.net and it's now back to normal :)

Hope this helps
 
1 - 3 of 3 Posts
Top